Updates to the Fiix CMMS sales system have been completed and the Account Settings page is now back online. For information on these enhancements, visit here:
Thank you for your patience during these scheduled CMMS improvements.
Posted Apr 30, 2025 - 13:29 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 28, 2025 - 17:21 EDT
Scheduled
The Account Settings page in Fiix CMMS will continue to be offline for upgrades until later this week. This means self-serve sales transactions, including quotes, license purchases, and tier upgrades will be temporarily unavailable.
All core Fiix CMMS features, including mobile, remain unaffected and fully operational. Only Account Settings is temporarily offline.
For urgent account management services, please contact your Customer Success team.
Note: If you are encountering a blank screen anywhere in your Fiix CMMS tenant, please clear your cache and try again. A fix has already been implemented for this known issue. For instructions on how to clear your cache, click the link below or contact support@fiixsoftware.com for assistance: