Work Request Portal Error

Incident Report for Fiix Software

Resolved

The issue concerning the Work Request Portalhas been resolved. If you are still having any issues with the WRP please contact support@fiixsoftware.com
Posted Sep 12, 2025 - 17:00 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 12, 2025 - 15:16 EDT

Update

We are continuing to implement a solution for the issue affecting WRP access.
Posted Sep 12, 2025 - 14:44 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 12, 2025 - 11:59 EDT

Update

We are continuing to investigate this issue.
Posted Sep 12, 2025 - 11:43 EDT

Investigating

We are currently investigating an issue with the Work Request Portal.
Posted Sep 12, 2025 - 11:34 EDT
This incident affected: Work Request Portal.