Delays in Work Request Portal (WRP) request processing

Incident Report for Fiix Software

Resolved

Request processing has returned to normal operation, and any delays experienced during the incident have been resolved.

If you continue to experience any issues, please contact Support at support@fiixsoftware.com.
Posted Sep 17, 2026 - 15:18 EDT

Identified

We have identified the source of the issue affecting Work Request Portal (WRP) request processing and are actively implementing mitigation measures. Some customers may continue to experience delays while processing returns to normal.

We will provide additional updates as more information becomes available.
Posted Sep 17, 2026 - 12:16 EDT
This incident affected: Work Request Portal.