Issue running some reports

Incident Report for Fiix Software

Resolved

This has been resolved . if you continue to have any issues with running reports please contact support@fiixsoftware.com for further assistance.
Posted Jun 16, 2025 - 13:47 EDT

Monitoring

A security based update affected some users ability to run some reports. This has now been resolved and we are monitoring .
If you continue to have any issues running reports, please contact support@fiixsoftware.com for assistance
Posted Jun 16, 2025 - 05:15 EDT
This incident affected: Fiix Desktop.