Service Disruption

Incident Report for Fiix Software

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 14:22 EST

Update

We are continuing to monitor for any further issues.
Posted Jan 27, 2026 - 14:22 EST

Monitoring

A fix has been implemented, and you should now be able to log back into your systems. We are continuing to monitor the situation to ensure stability.
If you continue to experience issues logging in, please reach out to support@fiixsoftware.com for assistance.
Posted Jan 23, 2026 - 13:12 EST

Update

We’re continuing to investigate a service disruption. Our engineering team is working to identify the root cause and implement a solution. Next update in 15 minutes
Posted Jan 23, 2026 - 12:52 EST

Investigating

We’re currently experiencing a service disruption. Our engineering team is working to identify the root cause and implement a solution. Next update in 15 minuttes
Posted Jan 23, 2026 - 12:37 EST
This incident affected: Fiix Desktop, Fiix Mobile, Work Request Portal, Analytics, Integrations, Dashboard Widgets and V6 (V6 Work Orders, V6 Equipment, V6 User Management).